Error with PHP 7.2.8

More
3 years 9 months ago #219 by Jochen.Ebert
Hello,
after my update to PHP 7.2.8, I get the following error on the page where a Netatmo module is displayed, or the entire page is no longer displayed.

Error: "[] operator not supported for strings"

I use:
Joomla 3.8.12
Digi netatmo 1.1.1
PHP 7.2.8

Is there perhaps a solution for this?

Thank you

Best regards
Jochen

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago #220 by Gregorio
Replied by Gregorio on topic Error with PHP 7.2.8
Hello,
yes, it's a common issue.

As is written on Digi Netatmo product page, at the moment: "Due of Netatmo API compatibility, this module cannot run on PHP > 7.0.28."

Here there is the official GitHub page of Netatmo PHP API: github.com/Netatmo/Netatmo-API-PHP

To let the module works well on PHP > 7 we are waiting the new release of Netatmo API, but we don't know exactly when it will be released.
At the moment, the only working solution is to keep PHP <= 7.0.28.

We are sorry for the inconvenience.

Once API update will be available, we will release a new version of Digi Netatmo.

Kind regards,
Greg

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago #221 by Jochen.Ebert
Replied by Jochen.Ebert on topic Error with PHP 7.2.8
Hello,

Thank you for the fast answer.

How long will it take, days, weeks or even months?

I need PHP 7.1 for another application. I would not like to take a step backwards with the PHP version.

Thank you

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago #222 by Jochen.Ebert
Replied by Jochen.Ebert on topic Error with PHP 7.2.8
Oh, i have see, you make a Error-Message at 27.04 in the Git-Hub.

Its a long time with no answer.

Thank you

Jochen

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago #223 by Gregorio
Replied by Gregorio on topic Error with PHP 7.2.8
Hi again.

I don't know what to answer regarding the time, becasue it does not depends from us. We are willing to have that update as soon as possible, because other users are requesting that. And PHP 7.0 going to be obsolete soon.

As well as, I hope to receive that update before the end of the year, because this version of PHP will be not supported anymore form the next year.

On the new module release we will publish a post on our Facebook page.
Keep in touch and sorry again.

Kind regards.

Please Log in or Create an account to join the conversation.

More
3 years 1 month ago #281 by Jochen.Ebert
Replied by Jochen.Ebert on topic Error with PHP 7.2.8
Hello,
as I saw today, there is now a new version of Digigreg Netatmo.
So far I had problems with the use of this module, because PHP7 is not supported.

Is this problem solved with the new version 2 now?

Today I tried to update my 1.1.1 to V2. This unfortunately failed.
When I signed in here, I realized that the download option had expired.

Do I have to buy the V2 again?

Thank you

Best regards
Jochen

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum