Forum

normal Error with PHP 7.2.8

More
1 year 1 month ago #288 by Gregorio
Replied by Gregorio on topic Error with PHP 7.2.8
That is really strange, as Digi Netatmo has translatable strings feature.

Is your Joomla German language tag de-DE?
Do you see all the module strings in English or only the weather measurements? I mean, the backend of the module is in German or in English? And you see in English all the frontend data?

Thanks,
Kind regards.

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #289 by Jochen.Ebert
Replied by Jochen.Ebert on topic Error with PHP 7.2.8
Hello Gregorio,

yes, it is very funny.

The backend and the frontend are in german.
All Joomla modules / components, as far as a German translation exists, I can see in German.

Netatmo displays both the modules and all texts in English when they are output.

Then I tried something.
Renamed the German language file accordingly (en-GB) and copied it into the en-GB language folder.
Then it looked very strange in the module and in the display.

Best regards
Jochen
Attachments:

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #290 by Jochen.Ebert
Replied by Jochen.Ebert on topic Error with PHP 7.2.8
Hello,

I then renamed the it-IT language file to en-GB and copied it to the en-GB language folder.
Since then all Netatmo modules and texts of the edition were displayed in Italian.
Only with the German language file does not work with me.

Best regards
Jochen

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #291 by Jochen.Ebert
Replied by Jochen.Ebert on topic Error with PHP 7.2.8
Hello,

strange.
If I rename the Italian language file to de-DE and copy it to the de-DE folder, everything will be displayed in Italian.
Now I'll take a closer look at the de-DE language file.

best regards
Jochen

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #292 by Jochen.Ebert
Replied by Jochen.Ebert on topic Error with PHP 7.2.8
Hello,

i have found the error in german language file.

MOD_DIGI_NETATMO_FIELD_BACKUP_LOAD_SETTINGS="Einstellungen laden“

The last character is not correct.
Now it's working.

Best regards
Jochen

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #293 by Gregorio
Replied by Gregorio on topic Error with PHP 7.2.8
Hi Jochen,
I'm going to take a look to the file and release a fixed-up version of the module soon.

Probably it's fault of my typing error, it can happen. Maybe it was hidden to my eyes as I often try English and Italian language files, because I don't speak a word of German.

Thanks for your debug,
keep in touch.
Cheers

Please Log in or Create an account to join the conversation.

Subscribe to our newsletter

  • Language:
  • Email: This email address is being protected from spambots. You need JavaScript enabled to view it.

This site uses cookies to improve navigation and services offered to the visitor. Cookies and their use, managed according to GDPR regulation, are automatically accepted if you choose to continue browsing this website.