Error with PHP 7.2.8

More
3 years 1 month ago #282 by Gregorio
Replied by Gregorio on topic Error with PHP 7.2.8
Hello Jochen,
Yes finally we've got the new version of Netatmo APIs which work with our module version 2.0.0, so now it's PHP 7.1 and PHP 7.2 compliant (yeah).

If you take a look in the module page (www.digigreg.com/en/products/joomla-modules/digi-netatmo.html), the version 2.0.0 introduces a bunch of new features too.
The complete changelog is:
- Finally you can connect your Netatmo Thermostat to the module
- Now it's possible to select more weather stations together
- New service data screen to control the status of your Netatmo devices
- jQuery library is loaded directly from Joomla so is not included in the module anymore
- General speed and connection improvements
- Netatmo API updated to the latest version
- Finally the module is compatible with PHP 7.2

Regarding the re-purchase of the module, as is written in our Terms and Conditions page (www.digigreg.com/en/terms-and-conditions.html), all paid products will be downloadable and updatable for 365 days after purchase (like the most Joomla extensions providers). So maybe it's mean that your order was made more than one year ago. If you are sure that your order was made less than one year ago, please open our module in your Joomla website to automatically regenerate the correct update site with your order password, then try again do update the module through the normal Joomla Update System.

Anyway, there is something to highlight: as I've written on our Faceook page, upgrading the module from 1.1.1 to 2.0.0 will requires to set again your Netatmo stations, Netatmo modules, and data you want to display. This happend because we made big changes into our module to let it be compatible with more than one Netatmo weather station together and finally, after so many requests, also with Netatmo thermostat.
So now you can display, for example, some data from your Netatmo weather station and its modules and some other data from your Netatmo Thermostat in the same module instance.

If you have further questions, feel free to ask, we will reply asap.
Kind regards.

Please Log in or Create an account to join the conversation.

More
3 years 1 month ago #283 by Jochen.Ebert
Replied by Jochen.Ebert on topic Error with PHP 7.2.8
Hello Gregorio,

thank you for the fast answer.

On the one hand, I can understand that new features also need to be paid.
On the other hand, I could not use the Netatmo module for a period of 8 months. This was also due to the fact that I could only operate my server with PHP7.
This is of course a little annoying.
The price increase from € 14.90 to € 39.90 makes the purchase of the V2 not easy, despite the additional features.
Is there perhaps a reduced price for existing customers?

Many Thanks

Kind regards.

Jochen

Please Log in or Create an account to join the conversation.

More
3 years 1 month ago #284 by Gregorio
Replied by Gregorio on topic Error with PHP 7.2.8
Hi Jochen,
I'm sorry for the increased price.

For us, the old price of the module (version 1) was a kind of launch price.
This module, with its simple look, requires a lot of time to be well-integrated with the Netatmo stuff and with the new APIs. Now even more because it can manage more weather stations and thermostats in the same time, with only one module instance.
Thanks for understanding that development time has to be paid.

Besides, if you want to share a photo of your beautiful Netatmo set up or a screenshot of our module on your website, them are welcome on the forum.

Kind regards.

Please Log in or Create an account to join the conversation.

More
3 years 1 month ago - 3 years 1 month ago #285 by Jochen.Ebert
Replied by Jochen.Ebert on topic Error with PHP 7.2.8
Hello,

have now done an update to the V2.

Finally, our club members can now look at the weather data from home again.
In bad weather it sometimes makes no sense to drive to the model airfield, because you can better go to the basement, build new models and these can rise in better weather in the air.

Thanks for the V2.

At the moment the data are unfortunately not yet displayed in German.
I have to look at the days then.



Best regards
Jochen
Attachments:
Last edit: 3 years 1 month ago by Gregorio.

Please Log in or Create an account to join the conversation.

More
3 years 1 month ago #286 by Gregorio
Replied by Gregorio on topic Error with PHP 7.2.8
Well done Jochen.

Sorry,can you tell me what do you miss in the German translation?
The module is translatable, and available in English, Italian and German. Anyway, maybe are some strings retrieved from Netatmo server not translatable?

Thanks,
Kind regards.

Please Log in or Create an account to join the conversation.

More
3 years 1 month ago #287 by Jochen.Ebert
Replied by Jochen.Ebert on topic Error with PHP 7.2.8
Hello,

that with the German language is like that.

My Joomla is set to German, the languages ​​English and German are installed, but German is defined as standard.

The Netatmo shows me but the texts of the values ​​in englich.

e.g. "Humidity" instead of "Feuchtigkeit"

Best regards

Jochen

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum