Article Categories bug

More
1 year 1 month ago #405 by Angerfeld
Hello, I'm creating a website for someone and I use Digi Showcase. I really like your extension but I encountered an issue I can explain nor resolve. Here's the thing : I created 2 pages; The first displays professional prices (each price is an article), the second one displays non-professional prices (same here).

The professional page is completely working, but when I click on an article displayed in the non-professional page, instead of showing me the complete article, it show Error 404 with this error message : Affichage introuvable [name, type, prefix] : 10forfaits-particuliers, html, contentView.

I tried to delete the non-professional module and to replace it by the Professional one, and just change the category of articles shown and the title, but it didn't help, my problem is still here.

I also tried to simply create a Joomla category article page to display all articles in the non-professional category, and it works perfectly. I do not understand where the problem is.

Please help me guys

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #407 by Gregorio
Replied by Gregorio on topic Article Categories bug
Hello Angerfeld,
sorry for the long delay, I had a week of holidays.

It looks like your website/template has something broken, like a view of the com_content. If I have translated correctly "Affichage introuvable" means "View not found". In case, I suggest to double check if your template has an override which is overriding badly the com_content for the destination page of your articles.

At least, from your description, it not seems to be a module issue.

Have you maybe found the cause?

Kind regards,
Gregorio

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #408 by Angerfeld
Replied by Angerfeld on topic Article Categories bug
Hello Gregorio ! I didn't say it and it might help, my template is Helix3.
I indeed found a little fix but it's not perfect. Somehow, deactivating SEF rewriting fixed my issue. However i'd like to find a better way to get rid of this inonvenience.

I am a true beginner in website building, and I do not know what is an override or how to see if it is a bad one or a good one.
Maybe I can send you screenshots?

Thanks

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #409 by Gregorio
Replied by Gregorio on topic Article Categories bug
Yes, you can send a screenshot through the forum.

To see if it's a problem of the template, try to set Protostar template as default for all the website and check again if the module works. If yes, it's fault of the template/override, if not, so the cause has to be searched somewhere else.

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #410 by Angerfeld
Replied by Angerfeld on topic Article Categories bug
I tried with SEF on and Protostar, but it didn't help.
I keep having the same error message.

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #411 by Gregorio
Replied by Gregorio on topic Article Categories bug
Try to disable SEF at all and set Protostar.
Then, please, paste here the non-SEF URL of the page where you are experiencing the issue (to see what view/page is called by Joomla).
As well as, maybe a screenshot of the page could help to understand better.

Two more questions:
1) Is "10forfaits-particuliers" an alias of one of your article where you have the issue?
2) Can you reach articles pages in the frontend where you are experiencing the issue (by module's links) through the normal Joomla menu? In case: create a Joomla menu item that calls the category where you've published those articles; then click on that menu item and open one article; then copy/paste the non-SEF URL and have a look if it's different from the one generated by the module for the same article. You can paste here on the forum both the non-SEF URLs, so I can have a look as well.

Thanks,
have a nice day.

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum